Breaking News

Amazon RDS ประกาศสนับสนุนการใช้งาน MySQL 8.0 ในทุก Region แล้ว

Amazon RDS for MySQL ได้ประกาศรองรับ MySQL Community Edition รุ่น 8.0 แล้วในทุกๆ AWS Region โดย MySQL 8.0 ที่ได้มีการปรับปรุงความสามารถในการ Query รูปแบบใหม่ๆ และเสริมประสิทธิภาพ ความทนทาน ความมั่นคงปลอดภัย ความสามารถในการบริหารจัดการ และอื่นๆ อีกมากมายนั้น มีความสามารถใหม่ๆ ที่น่าสนใจดังนี้

 

Credit: AWS

 

  • เพิ่ม Windows Functions และ Common Table Expression (คำสั่ง WITH) เพื่อลดความซับซ้อนในการ Query ลง
  • เพิ่มความสามารถใหม่ๆ ในการจัดการกับ JSON เช่น การแปลง JSON ให้อยู่ในรูป Relational Table, การ Merge JSON Object, การทำ Aggregation เป็นต้น
  • เพิ่มความสามารถด้าน GIS โดยรองรับ Spatial Data Type, Index และคำสั่งต่างๆ เพื่อสนับสนุน Spatial Reference Systems กว่า 5108 รูปแบบ
  • เร็วกว่า MySQL 5.7 ถึง 2 เท่า มีการปรับปรุงประสิทธิภาพให้กับ InnoDB รวมถึงเพ่มประสิทธิภาพในการทำ Replication และอื่นๆ อีกมากมาย
  • ทนทานด้วยการทำงานแบบ Atomic, ทำ Crash-safe DDL ได้ และมี Unified, Transactional Data Dictionary สำหรับ Metadata ด้วย
  • เพิ่มระบบ Role เพื่อกำหนดสิทธิ์ให้กับผู้ใช้งาน, กำหนดนโยบายการตั้งรหัสผ่านได้ดีขึ้น และใช้ OpenSSL เป็น Default Library สำหรับ TLS/SSL
  • เพิ่มความสามารถในการบริหารจัดการใหม่ๆ เข้ามา
  • ใช้ utf8mb4 เป็น Default Character Set

 

ผู้ที่สนใจสามารถศึกษา User Guide ได้ที่ https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/CHAP_MySQL.html ครับ

 

ที่มา: https://aws.amazon.com/about-aws/whats-new/2018/10/amazon-rds-now-supports-mysql-8/


About techtalkthai

ทีมงาน TechTalkThai เป็นกลุ่มบุคคลที่ทำงานในสาย Enterprise IT ที่มีความเชี่ยวชาญทางด้าน Network, Security, Server, Storage, Operating System และ Virtualization มารวมตัวกันเพื่ออัพเดตข่าวสารทางด้าน Enterprise IT ให้แก่ชาว IT ในไทยโดยเฉพาะ

Check Also

DigitalOcean ออกบริการ Managed-service ของ MySQL และ Redis

DigitalOcean ผู้ให้บริการ Cloud ได้ออกบริการ Managed-service ของ MySQL และ Redis เพื่อรองรับการใช้งานของนักพัฒนาที่มีลูกค้าเรียกร้องกันเข้ามา

พบช่องโหว่กระทบ Kubernetes ทุกเวอร์ชัน แนะควรอัปเดต

พบช่องโหว่ 2 รายการที่ส่งผลกระทบกับ Kubernetes ทุกเวอร์ชัน ที่สามารถนำไปสู่การเกิด Denial-of-service จึงแนะนำให้ผู้ทำการอัปเดต